1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1
Sample Output:

41
题目大意:一栋楼只有一部电梯,现在给出将要到达楼层的列表,请按顺序依次前往个楼层。

分析:题目清楚明白、浅显易懂,不再分析!

参考代码:

#include<iostream>

using namespace std;

int main()
{
    int n, prenum = 0, num, totalSecond = 0;
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> num;
        int floors = num - prenum;
        if (floors > 0)
        {
            totalSecond += (floors) * 6 + 5;
        }
        else if(floors<0)
        {
            totalSecond += abs(floors) * 4 + 5;
        }
        else if (floors == 0)
        {
            totalSecond += 5;
        }
        prenum = num;
    }
    cout << totalSecond;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81411561
今日推荐