数据结构上机测试2-2:单链表操作B SDUT—1139

数据结构上机测试2-2:单链表操作B

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数n;
第二行输入n个整数。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

Source

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

struct node
{
    struct node *next;
    int data;
}*head, *tail, *p, *q;
struct node *creat(int n)
{
    int i;
    struct node *head, *p;
    head=(struct node*)malloc(sizeof(struct node));head -> next = NULL;
    for(i = 0; i < n; i++)
    {
        p = (struct node*)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p -> next = head -> next;head -> next = p;
    }
    return head;
};
void show (struct node *head)
{
    struct node *t;
    t = head -> next;
    while(t)
    {
        if(t -> next != NULL)printf("%d ", t -> data);
        else printf("%d\n", t -> data);
        t = t -> next;
    }
}
int main()
{
    int n;
    scanf("%d", &n);head = creat(n);
    printf("%d\n", n);show(head);
    p = head -> next;
    while(p != NULL)
    {
        tail = p;q = p -> next;
        while(q != NULL)
        {
            if(q -> data == p -> data)
            {
                tail -> next = q -> next;q = tail -> next;n--;
            }
            tail = tail -> next;q = q->next;
        }
        p = p-> next;
    }
    printf("%d\n", n);show(head);
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Allinone99/article/details/81332618