Constructing Roads 克鲁斯卡尔

题目表述:

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

输入:

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

输出:

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

样例输入:

3
0 990 692
990 0 179
692 179 0
1
1 2

样例输出:

179

大体题意就是还需要修多少路可以使全部的村庄都可以连接在一起,需要注意的是定义数组的时候要定义的大一点,否则提交的时候回runtime;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
int n,q,a,b,s;
int par[5000],l[5000][5000];//定义数组要大一点
struct node
{
    int u,v,w;
}ds[5000];
int FIND(int x)
{
    return par[x]==x?x:(par[x]=FIND(par[x]));
}
bool cmp(node a,node b)
{
    return a.w<b.w;
}
void combine(int x,int y)
{
    int xx=FIND(x);
    int yy=FIND(y);
    if(xx!=yy)
        par[xx]=yy;
}
int kruskal()
{
    sort(ds+1,ds+1+s,cmp);//题目中说村庄从1开始,所以这里要都加1,因为数组开头的下标是0
    int sum=0;
    for(int i=1;i<=n;i++)
        par[i]=i;//初始化每个村庄的根节点
        for(int i=1;i<=s;i++)
        {

    if(FIND(ds[i].u)!=FIND(ds[i].v))
    {
        combine(ds[i].u,ds[i].v);
        sum+=ds[i].w;
    }
}
  return sum;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
       s=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&l[i][j]);
                if(j>i)//这个地方是避免重复输入,因为从对角线两边是对称的,所以只输入上三角或者是下三角就行了,这个地方如果全输入的话,s会比这么输入大,然后提交就runtime了,可能这样会减少时间
                {
                ds[++s].u=i;
                ds[s].v=j;
                ds[s].w=l[i][j];
                }
            }
        }
        scanf("%d",&q);
        while(q--)
        {
           scanf("%d%d",&a,&b);

            for(int i=1;i<=s;i++)
            {
                if((ds[i].u==a&&ds[i].v==b)||(ds[i].u==b&&ds[i].v==a))//因为我们需要加的是还需要建多少能全部连通,而这些已经连通的已经不需要再加了,所以把他们的权值赋0
                    {
                    ds[i].w = 0;
                    break;

                    }

            }
            combine(a,b);
        }


        printf("%d\n",kruskal());
    }
}


 

猜你喜欢

转载自blog.csdn.net/zhangjinlei321/article/details/81269825
今日推荐