【HDU - 5605】 geometry(水,数学题,推公式)

题干:

There is a point PP at coordinate (x,y)(x,y). 
A line goes through the point, and intersects with the postive part of X,YX,Yaxes at point A,BA,B. 
Please calculate the minimum possible value of |PA|∗|PB||PA|∗|PB|.

Input

the first line contains a positive integer T,means the numbers of the test cases. 

the next T lines there are two positive integers X,Y,means the coordinates of P. 

T=500T=500,0<X,Y≤100000<X,Y≤10000. 

Output

T lines,each line contains a number,means the answer to each test case. 


 

Sample Input

1
2 1

Sample Output

4

in the sample $P(2,1)$,we make the line $y=-x+3$,which intersects the positive axis of $X,Y$ at (3,0),(0,3).$|PA|=\sqrt{2},|PB|=2\sqrt{2},|PA|*|PB|=4$,the answer is checked to be the best answer.

解题报告:

AC代码:

扫描二维码关注公众号,回复: 2582763 查看本文章
#include<bits/stdc++.h>

using namespace std;

int main()
{
	int t;
	cin>>t;
	while(t--) {
		int x,y;
		cin>>x>>y;
		printf("%d\n",2*x*y);
	}
	
	return 0 ;
 } 

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/81430899
今日推荐