codeup1918问题 A: 简单计算器

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出

12178.21
#include<iostream>
#include<string>
#include<stack>
#include<fstream>
#include<queue>
#include<map>
using namespace std;

struct node{
	double num;
	char op;
	bool flag;
};

string str;								//中缀表达式 
stack<node> s;							//操作符栈 
queue<node> q;							//后缀表达式序列 
map<char, int> op;						//操作符和优先级的映射 

void change(){							//将中缀表达式转换为后缀表达式 
	node temp;
	for(int i=0; i<str.length();){
		if(str[i]>='0' && str[i]<='9'){
			temp.flag=true;
			temp.num=str[i++]-'0';
			while(i<str.length() && str[i]>='0' && str[i]<='9'){
				temp.num=temp.num*10+(str[i]-'0');
				i++;
			}
			q.push(temp); 
		} else{
			temp.flag=false;
			while(!s.empty() && op[str[i]]<=op[s.top().op]){
				q.push(s.top());
				s.pop();
			}
			temp.op=str[i];
			s.push(temp);
			i++; 
		}
	}
	while(!s.empty()){
		q.push(s.top());
		s.pop(); 
	}
}

double cal(){
	double temp1, temp2;
	node cur, temp;
	while(!q.empty()){
		cur=q.front();
		q.pop();
		if(cur.flag==true) s.push(cur);
		else{
			temp2=s.top().num;
			s.pop();
			temp1=s.top().num;
			s.pop();
			temp.flag=true;
			if(cur.op=='+') temp.num=temp1+temp2;
			else if(cur.op=='-') temp.num=temp1-temp2;
			else if(cur.op=='*') temp.num=temp1*temp2;
			else temp.num=temp1/temp2;
			s.push(temp); 
		}
	}
	return s.top().num;
}

int main(){
	op['+']=op['-']=1;
	op['*']=op['/']=2;
//	freopen("d://in.txt","r",stdin);
	while(getline(cin, str), str!="0"){
		for(string::iterator it=str.begin(); it!=str.end(); it++){
			if(*it==' ') str.erase(it); 
		}
		while(!s.empty()) s.pop();
		change();
		printf("%.2f\n", cal());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Chuyuan_li/article/details/81431616