HDU 2648 Shopping(map的简单用法)

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's price after the change of everyday.

Input

One line contians a number n ( n<=10000),stands for the number of shops. 
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop. 
Then a line contians a number m (1<=m<=50),stands for the days . 
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s. 

Output

Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2

注意英语,price has increased s. 是价格增加了s,并不是增加到。增加到是increase to

其他的就是map的用法了

#include <iostream>
#include <map>

using namespace std;

//map<string ,int> shop;//默认按key排序
typedef map <string,int> mp;
mp shop;

void fun()
{
//    map <string,int> ::iterator it 这个也可以
    mp::iterator it;//迭代器的使用
    string s="memory";
    int val;
    for(it=shop.begin(); it!=shop.end(); it++)
    {
        if(it->first ==s) val= it->second;
    }
    int ans1=0;
    for(it=shop.begin(); it!=shop.end(); it++)
    {
        if(it->second > val && it->first!=s)
            ans1++;
    }
    cout<<ans1+1<<endl;
}
int main()
{
    int n,val,day;
    string s;
    while(cin>>n)
    {
        shop.clear();
        for(int i=0; i<n; i++)
        {
            cin>>s;
            shop[s]=0;//默认为零,这句也可以不要
        }
        cin>>day;
        for(int i=0; i<day; i++)
        {
            for(int j=0; j<n; j++)
            {
                cin>>val>>s;
                shop[s]+=val;
            }
            fun();
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40733911/article/details/81430502