出现(n+1)/2次的数

B - Ignatius and the Princess IV

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says. 

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

"But what is the characteristic of the special integer?" Ignatius asks. 

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

Can you find the special integer for Ignatius? 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 

Output

For each test case, you have to output only one line which contains the special number you have found. 

Sample Input

5

1 3 2 3 3

11

1 1 1 1 1 5 5 5 5 5 5

7

1 1 1 1 1 1 1

Sample Output

3

5

1

动态规划:

题目大意就是在一组数中寻找一个出现超过(或等于)一半的数。
因此,我们可以将该数组分为两部分,一部分是等于要寻找的数x,一部分是不等于x的数,因此有:x出现的次数>=不等于它的出现的数的次数,从而可以假设该数为x,当后边出现的数等于x时,将其计数值times(初始值为0)加一,否则减一,当times==0时,则表明肯定不是该数,从而又假设x等于当前读入的数t,按照这种方法可以得到结果

AC代码

#include <stdio.h>
int main()
{
	int n, k, charactor, times;
	while (EOF != scanf("%d", &n))
    {
	    times = 0;
        while(n--)
        {
            scanf("%d", &k);
            if (times<=0) charactor=k;
	        (k==charactor) ? (++times) : (--times);
	    }
	    printf("%d\n", charactor);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq1013459920/article/details/81134551
今日推荐