TOYS

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

这道暴力求出每个挡板的方程斜率k,和b。x=ky+b因为有垂直情况所以x为因变量。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
#define LL long long
struct nomd
{
	double x2,y2,x1,y1,k,b;
	int num;
}p[5006];
int panduan(double a,double b,int i)
{
	if(p[i].k==0)
	{
		if(a<p[i].x1&&a<p[i].x2)
		return 1;
		return 0;
	}
	if(p[i].b+b*p[i].k<a)
	return 0;
	else
	return 1;
}
int cmp(nomd a,nomd b)
{
	if(a.x2==b.x2)
	return a.x1<b.x1;
	return a.x2<b.x2;
}
int main()
{
	int n,m;
	while(scanf("%d",&n),n!=0)
	{
		memset(p,0,sizeof(p));
		double a,b,a1,b1;
		scanf("%d %lf %lf %lf %lf",&m,&a,&b,&a1,&b1);
		for(int i=0;i<n;i++)
		{
	  		scanf("%lf %lf",&p[i].x1,&p[i].x2);
			  p[i].y1=b;p[i].y2=b1;	
			  p[i].k=(p[i].x2-p[i].x1)/(p[i].y2-p[i].y1);
			  p[i].b=p[i].x1-p[i].k*p[i].y1;
		}
		p[n].x1=a1;p[n].x2=a1;p[n].y1=b,p[n].y2=0;
		sort(p,p+n+1,cmp);
		for(int i=0;i<m;i++)
		{
			double e,ee;
			scanf("%lf %lf",&e,&ee);
			for(int j=0;j<=n;j++)
			{
				if(panduan(e,ee,j)==1)
				{
					p[j].num++;break;
				}
			}
		}
		for(int i=0;i<=n;i++)
		{
			printf("%d: %d\n",i,p[i].num);
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/liuliu2333/article/details/81226370