F - Currency Exchange

来源poj1860

everal currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

一直换下去,到了换过反而比之前少的时候就判断有没有比之前的钱多

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<stack>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+100;
const double eps=1e-8;
using namespace std;
const double pi=acos(-1.0);
const int inf=0xfffffff;
const int N=105;
double dist[N],rate[N][N],cost[N][N];
int n,m,s,x,y;
double num,a1,b1,a2,b2;
struct edge
{
    int b,e;
    double rate,cost;
}v[N*2];
bool Bellman()
{
    rep(i,1,n+1)
    dist[i]=0;
    dist[s]=num;
    while(dist[s]<=num+eps)//比原有的多就可以跳出循环,没必要继续换钱 
    {
        int temp=1;
        rep(i,0,2*m)
        {
            double cas=(dist[v[i].b]-v[i].cost)*v[i].rate;//算能不能换钱,能的话可以换多少 
            if(cas>dist[v[i].e]+eps)//如果之前是没有钱的,就会变成这么多,如果换过了的,说明循环了一圈,如果没有比之前多,也就意味着通过这样换不能变多钱 
            {
                temp=0;
                dist[v[i].e]=cas;
            }
        }
        if(temp)//到了不能变更多钱的时候,就比较现在拥有的钱和原来相比有没有更多 
        return dist[s]>num;
    }
    return true;
}
int main()
{
    while(scanf("%d%d%d%lf",&n,&m,&s,&num)!=EOF)
    {
        rep(i,0,m)
        {
            cin>>x>>y>>a1>>b1>>a2>>b2;
            v[i].b=x;v[i].e=y;v[i].rate=a1;v[i].cost=b1;
            v[i+m].b=y;v[i+m].e=x;v[i+m].rate=a2;v[i+m].cost=b2;
        }
        if(Bellman())
        cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
        return 0;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wzl19981116/p/9442960.html