B - Flip Game POJ - 1753

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

解题思路:用递归从第一个点开始尝试,如果成功了,更新最小值,并返回。之后把这个点在变回来。然后在进入到递归中,寻找下一个点。知道 遍历完所有点。

代码如下:

#include<stdio.h>
#include<string.h>
#define inf 999999
char s[5][5];
int book[5][5];
int minn;
int cherk()     //检查是否已到达目的。
{
    int i,j;
    for(i=0; i<4; i++)
        for(j=0; j<4; j++)
            if(s[i][j]!=s[0][0])
                return 0;
    return 1;
}
int nextt[5][2]= {{0,0},{0,1},{1,0},{-1,0},{0,-1}};
void bian(int x,int y)  //改变本身和周围的棋子
{
    int tx,ty,i,j;
    for(i=0; i<5; i++)
    {
        tx=x+nextt[i][0];
        ty=y+nextt[i][1];
        if(tx<0||tx>=4||ty<0||ty>=4)
            continue;
        if(s[tx][ty]=='b')
            s[tx][ty]='w';
        else
            s[tx][ty]='b';
    }
}
void dfs(int x,int y,int sum)
{
    int tx,ty,i,j,k;
    if(cherk())
    {
        if(sum<minn)     //记录最小的变换次数
            minn=sum;
        return;
    }
    if(x==4) return;    //超出边界
    bian(x,y);
    if(y==3)         
        dfs(x+1,0,sum+1);  //递归到下一行
    else
        dfs(x,y+1,sum+1);   //递归到下一列
    bian(x,y);
    if(y==3)
        dfs(x+1,0,sum);     //把上一次的变换次数取消掉,并尝试下一个点。
    else
        dfs(x,y+1,sum);
    return;
}
int main()
{
    while(~scanf("%s",s[0]))
    {
        for(int i=1; i<4; i++)
            scanf("%s",s[i]);
        minn=inf;
        dfs(0,0,0);
        if(minn<16)           //变换次数不会超过16次
            printf("%d\n",minn);
        else
            printf("Impossible\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/TANG3223/article/details/81225907