G - Anagrams by Stack

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT: 


i i i i o o o o 
i o i i o o i o 


where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second. 

A stack is a data storage and retrieval structure permitting two operations: 

Push - to insert an item and 
Pop - to retrieve the most recently pushed item 
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence: 

i i o i o o is valid, but 
i i o is not (it's too short), neither is 
i i o o o i (there's an illegal pop of an empty stack) 

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first. 

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by 




and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]

思路:用回溯法求出所有进出栈的问题。

#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
using namespace std;
char s1[10005],s2[10005],str[10005];
int l1,l2;
stack<char>q;
void dfs(int x,int y,int z)
{
    if(y==l2)
    {
        for(int i=0;i<z;i++)
            printf("%c ",str[i]);
        printf("\n");
        return;
    }
    if(x!=l1)
    {
        q.push(s1[x]);
        str[z]='i';
        dfs(x+1,y,z+1);
        q.pop();
    }
    if(!q.empty())
    {
        if(q.top()==s2[y])
        {
            q.pop();
            str[z]='o';
            dfs(x,y+1,z+1);
            q.push(s2[y]);
            str[z]='i';
        }
    }
}
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        while(!q.empty())
            q.pop();
        printf("[\n");
        l1=strlen(s1);
        l2=strlen(s2);
        dfs(0,0,0);
        printf("]\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lihuanz/article/details/81227158
今日推荐