FZU - 2150 Fire Game(两点bfs)

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题目大意:
两个熊孩子在n*m的平地上放火玩,#表示草,两个熊孩子分别选一个#格子点火,火可以向上向下向左向右在有草的格子蔓延,点火的地方时间为0,蔓延至下一格的时间依次加一。求烧完所有的草需要的最少时间。如不能烧完输出-1。
题解:
orz 向各位大佬先跪一波,,,
我一直以为两点bfs是开两个bfs来做,,,答案可想而知,,,
后来知道可以通过一个队列实现,,,emmmm 而且搜索时可以直接暴力???只需记录要搜索哪些就可???长见识了,,,

一开始我没有写

        if(cnt <= 2)
            printf("Case %d: 0\n", cas);

因为我觉得不需要吧,,,直到wa了才知道必须得判断是否 # 已超过两个,难道是因为可以只有一个 # ? 我一直以为两个熊孩子就一定会是两个 # 即以上,还是我考虑不周到啊,,,果真还是要向大佬先跪一波orz

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;

int n, m, cnt;
int d[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
bool vis[15][15];
char mp[15][15];
const int inf = 0x3f3f3f3f;

struct node{
    int x, y;
    int step;
}lu[100];

int bfs(node a, node b){
    memset(vis, 0, sizeof(vis));
    queue<node> q;
    node q1, ne;
    q.push(a);
    q.push(b);
    vis[a.x][a.y] = 1;
    vis[b.x][b.y] = 1;
    int maxn = 0;
    while(!q.empty()){
        q1 = q.front();
        q.pop();
        maxn = max(maxn, q1.step);
       // cout <<"maxn = " <<maxn << endl;
        for(int i = 0; i < 4; i++){
            ne.x = q1.x + d[i][0];
            ne.y = q1.y + d[i][1];
            ne.step = q1.step + 1;
            if(vis[ne.x][ne.y] || ne.x < 0 || ne.y < 0 ||ne.x >= n || ne.y >= m || mp[ne.x][ne.y] == '.')
                continue;
            vis[ne.x][ne.y] = 1;
            q.push(ne);
        }
    }
    //cout <<"maxn = " <<maxn << endl;
    return maxn;
}

int main(){
    int t, ans, sum;
    bool flag;
    scanf("%d", &t);
    for(int cas = 1; cas <= t; cas++){
        cnt = 0;
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++){
            scanf("%s", &mp[i]);
            for(int j = 0; j < m; j++){
                if(mp[i][j] == '#'){
                    lu[cnt].x = i;
                    lu[cnt].y = j;
                    lu[cnt].step = 0;
                    cnt++;
                }
            }
        }
        if(cnt <= 2)
            printf("Case %d: 0\n", cas);
        else{
            ans = inf;
            for(int i = 0; i < cnt; i++){
                for(int j = i+1; j < cnt; j++){
                    sum = bfs(lu[i], lu[j]);
                    flag = 0;
                    for(int k = 0; k < n; k++){
                        for(int l = 0; l < m; l++){
                            if(mp[k][l] == '#' && !vis[k][l]){
                                flag = 1;
                                //  cout << "flag = " << flag << endl;
                                break;
                            }
                        }
                        if(flag)
                            break;
                    }
                    if(!flag)
                        ans = min(ans, sum);
                }
            }
            if(ans == inf)
                printf("Case %d: -1\n", cas);
            else
                printf("Case %d: %d\n", cas, ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81449919