【next_permutation暴力+剪枝】2018 hdu多校第五场 1002 Beautiful Now

Beautiful Now

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 626    Accepted Submission(s): 196

 

Problem Description

Anton has a positive integer n, however, it quite looks like a mess, so he wants to make it beautiful after k swaps of digits.
Let the decimal representation of n as (x1x2⋯xm)10 satisfying that 1≤x1≤9, 0≤xi≤9 (2≤i≤m), which means n=∑mi=1xi10m−i. In each swap, Anton can select two digits xi and xj (1≤i≤j≤m) and then swap them if the integer after this swap has no leading zero.
Could you please tell him the minimum integer and the maximum integer he can obtain after k swaps?

Input

The first line contains one integer T, indicating the number of test cases.
Each of the following T lines describes a test case and contains two space-separated integers n and k.
1≤T≤100, 1≤n,k≤109.

Output

For each test case, print in one line the minimum integer and the maximum integer which are separated by one space.

Sample Input

12 1

213 2

998244353 1

998244353 2

998244353 3

Sample Output

12 21

123 321

298944353 998544323

238944359 998544332

233944859 998544332

Source

2018 Multi-University Training Contest 5

Recommend

chendu   |   We have carefully selected several similar problems for you:  6361 6360 6359 6358 6357 

#include <bits/stdc++.h>
using namespace std;
char a[20];
int c[20],q[20],q1[20],p[20],k,len;
int minn,maxx;

void update()
{
	if(c[p[1]]==0) return; //第一位数字是0,不符合规则
	for(int i=1;i<=len;i++) q[i]=p[i]; //q数组内保存全排列后的位置
	int k1=0,s=0;
	for(int i=1;i<=len;i++)
	{
		s=s*10+c[p[i]];
		if(q[i]!=i) //如果当前位数字更改了
		{
			for(int j=i+1;j<=len;j++)
			{
				if(q[j]==i)
				{
					swap(q[i],q[j]);
					k1++;
					if(k1>k) return;
					break;
				}
			}
		}
	}
	if(k1>k) return;//转换了超过k次,就不行,可以的话,再看
	maxx=max(maxx,s);
	minn=min(minn,s);
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		memset(q,0,sizeof(q));
		memset(q1,0,sizeof(q1));
		scanf("%s%d",a+1,&k);
		len=strlen(a+1);
		for(int i=1;i<=len;i++)
		{
			c[i]=a[i]-'0';
			q[c[i]]++;
			q1[c[i]]++;
		}
		if(k>=len-1)  //直接得到最大最小!!!不加等于就TLE
		{
			for(int i=1;i<=9;i++)
			{
				if(q[i])
				{
					printf("%d",i);
					q[i]--;
					break;
				}
			}
			for(int i=0;i<=9;i++)
			{
				while(q[i])
				{
					printf("%d",i);
					q[i]--;
				}
			}
			printf(" ");
			for(int i=9;i>=0;i--)
			{
				while(q1[i])
				{
					printf("%d",i);
					q1[i]--;
				}
			}
			printf("\n");
			continue;
		}
		for(int i=1;i<=len;i++) p[i]=i;  //每一位数字原来保存在哪里
		minn=2e9,maxx=-1;
		do
		{
			update();
		}
		while(next_permutation(p+1,p+len+1)) ;//全排列
		printf("%d %d\n",minn,maxx);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81460996