Best Cow Line, Gold(贪心)

Description

FJ is about to take his N (1 ≤ N ≤ 30,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input 

6

A

C

D

B

C

B

Sample Output

ABCBCD

Source

USACO 2007 December Gold

解题思路:

字典最小序问题。

题目意思为,输入一个字符串S,要求构建一个字典最小序列T,并且只能从S的头,或者尾删除字符插入到T中。

只要用两个指针分别指像字符串的头尾,然后依次进行比较,把小的插入到T中,如果所指元素相同,那么指针同时移动。

代码:

#include<stdio.h>
#include<iostream>
#define maxn 30000+10
char s[maxn];
using namespace std;
int main()
{
    int n;
    int num = 0;
    scanf("%d",&n);
    getchar();
    for(int i = 0;i < n;i++){
        scanf("%c",&s[i]);
        getchar();
    }
    int a = 0, b = n - 1;
    while(a <= b){
        bool left = false;
        for(int i = 0;a+i <= b-i;i++){ //左右指针所指元素相同时指针移动,防止指针越界
            if(s[a+i] < s[b-i]){
                left = true;
                break;
            }
            else if(s[a+i] > s[b-i]){
                left = false;
                break;
            }
        }
        if(left){
            printf("%c",s[a++]);
            num++;
            if(num % 80 == 0) //控制80个字符换行
            printf("\n");
        }
        else {
            printf("%c",s[b--]);
            num++;
            if(num % 80 ==0)
            printf("\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_42018521/article/details/81537218
今日推荐