Double Queue 用元素为结构体的set解决

Double Queue

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1456    Accepted Submission(s): 734


 

Problem Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.
 

 

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.
 

 

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.
 

 

Sample Input

 

2 1 20 14 1 30 3 2 1 10 99 3 2 2 0

 

Sample Output

 

0 20 30 10 0

 

Source

Southeastern Europe 2007

定义了三个操作

1:加入客户号和客户优先级

2:将当前优先级最高的客户移除

3:将当前优先级最低的客户移除

我用的是结构体,我居然用erase删除set的end(),程序异常输出,我找了一个小时,十分钟的题让我......,

另外,让迭代器减一会报错,需新生成一个迭代器,再赋给新的迭代器。

#include<iostream>
#include<cstdio>
#include<set>
#include<algorithm>
using namespace std;
struct kk
{
    int priority;
    int num;
};
bool operator < (const kk &x,const kk &y)
{
    return x.priority>y.priority;
}
int main()
{
    multiset<kk> w;
    kk s;
    s.num=0;
    s.priority=0;
    int i,j,t,n,m,k;
    w.clear();
    set<kk>::iterator id;
    while(~scanf("%d",&n),n)
    {
        if(n==1)
        {
            cin>>m>>t;
            s.num=m;
            s.priority=t;
            w.insert(s);
        }
        else if(n==2)
        {
            if(!w.empty())
            {
                cout<< (*(w.begin())).num<<endl;
                w.erase(w.begin());
            }
            else
            cout<<0<<endl;
            
        }
        else if(n==3)
        {
            id=w.end();
            id--;
            cout<<id->num<<endl;
            w.erase(id);
            
        }
        
    }
    
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/81566427