暑假集训day7——数据结构实验之二叉树二:遍历二叉树

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa
cgefdba

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

char s[100];
int top;

struct node
{
    char data;
    struct node *l, *r;

}*root;

struct node *creat()
{
    struct node *root;//注意这里每次进入之后都会重新拥有一个根节点

    if(s[++top] == ',')
    {
        root = NULL;
    }

    else
    {
        root = (struct node *)malloc(sizeof(struct node));
        root-> data = s[top];

        root-> l = creat();   //建立左儿子
        root-> r = creat();  //建立右儿子
    }

    return root;
}

void mid(struct node *root)   //中序遍历
{
    if(root)
    {
        mid(root-> l);   //左

        printf("%c", root-> data);  //中

        mid(root-> r);  //右
    }
}

void hou(struct node *root) //后序遍历
{
    if(root)
    {
        hou(root-> l);  //左
        hou(root-> r);  //右
        printf("%c", root-> data);  //中
    }
}

int main(void)
{
    while(gets(s) != NULL)
    {
        top = -1;

        root = creat();

//利用递归的方法

        mid(root); 

        printf("\n");

        hou(root);

        printf("\n");
    }

    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/Eider1998/article/details/81475103