Rescue The Princess(计算几何 旋转角度后下x,y的变化)

Rescue The Princess

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

    Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the princess.

    Now, here comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess snugly. He marked two coordinates of an equilateral triangle in the maze. The two marked coordinates are A(x1,y1) and B(x2,y2). The third coordinate C(x3,y3) is the maze’s exit. If the prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1) and B(x2,y2), but he doesn’t know where the C(x3,y3) is. The prince need your help. Can you calculate the C(x3,y3) and tell him?

Input

    The first line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow. Each test case contains two coordinates A(x1,y1) and B(x2,y2), described by four floating-point numbers x1, y1, x2, y2 ( |x1|, |y1|, |x2|, |y2| <= 1000.0).
    Please notice that A(x1,y1) and B(x2,y2) and C(x3,y3) are in an anticlockwise direction from the equilateral triangle. And coordinates A(x1,y1) and B(x2,y2) are given by anticlockwise.

Output

    For each test case, you should output the coordinate of C(x3,y3), the result should be rounded to 2 decimal places in a line.

Sample Input

4
-100.00 0.00 0.00 0.00
0.00 0.00 0.00 100.00
0.00 0.00 100.00 100.00
1.00 0.00 1.866 0.50

Sample Output

(-50.00,86.60)
(-86.60,50.00)
(-36.60,136.60)
(1.00,1.00)


kuangbin模板(不过要注意先以A1为原点计算再转化回来)

//绕原点旋转角度B(弧度值),后x,y的变化  
void transXY(double B)  
{   
    double tx = x,ty = y;   
    x = tx*cos(B) - ty*sin(B);   
    y = tx*sin(B) + ty*cos(B);  
}

代码:

#include <iostream> 
#include<cmath>
#include<cstdio>
using namespace std;

const double pi = acos(-1.0);
double x11, y11, x22, y22;
double x, y;
void transXY(double B)
{
	double tx = x, ty = y;
	x = tx*cos(B) - ty*sin(B);
	y = tx*sin(B) + ty*cos(B);
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%lf%lf%lf%lf", &x11, &y11, &x22, &y22);
		x = x22 - x11;
		y = y22 - y11;
		transXY((pi / 3));
		printf("(%.2lf,%.2lf)\n", x + x11, y + y11);


	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Xuedan_blog/article/details/80177645