(循环链表)约瑟夫问题

约瑟夫问题

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

n个人想玩残酷的死亡游戏,游戏规则如下: 

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。

Input

输入n和m值。

Output

输出胜利者的编号。

Sample Input

5 3

Sample Output

4

Hint

第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    int data;
    struct node *next;
} *head, *tail, *p, *q;
int main()
{
    int n, m, i;
    head = (struct node *)malloc(sizeof(struct node));
    head->data = 1;
    tail = head;
    scanf("%d %d", &n, &m);
    for(i = 2; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->next = NULL;
        p->data = i;
        tail->next = p;
        tail = p;
    }
    tail->next = head;
    q = tail;  // 指向head前边那个节点
    /*while(q->next != head)
    {
        q = q->next; // 循环后的结果即q = tail
    }*/
    int num = 0;
    while(q->next != q)
    {
        p = q->next;
        num++;
        if(num % m == 0)
        {
            q->next = p->next;
            //printf("%d ", p->data);
            free(p);
        }
        else
        {
            q = p;
        }
    }
    printf("%d\n", q->data); // 输出的是q->data,因为之前是用q进行的游动
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011145745/article/details/81382934