1054 求平均值

1054 求平均值(20 分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K为 1,则输出 The average of 1 number is Y

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

分析:用一个string读入字符串,然后写一个函数一一筛查即可,下面列出具体具体筛查过程:

1.字符只包括数字 . -

2.- 最多只能出现一次,并且如果出现一次,还只能是在开始的位置。

3. . 也最多只能出现一次,并且不能在开头,而且小数点位数不能超过2

4.数据范围在[-1000,1000] 

其他细节,比如合法数字等于1, 是number

#include<iostream>
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
bool isLegal(string s)
{
	int i;
	int point = 0;
	int pointf = 0;
	for (i = 0; i < s.length(); i++)
	{
		if (!(s[i] >= '0' && s[i] <= '9') && (s[i] != '.') && s[i] != '-') return false;
		if (s[i] == '.')  point++;
		if (s[i] == '-') pointf++;
	}
	if (pointf > 1) return false;
	if (pointf == 1 && s[0] != '-') return false;
	if (pointf == 1 && s.length() == 1) return false;
	if (point > 1) return false;
	if (point == 1 && s.length() - s.find('.') > 3) return false;
	if (point == 1 && s[0] == '.') return false;
	double temp = stof(s);
	if (temp < -1000 || temp > 1000) return false;
	return true;
}
int main()
{
	string s;
	int i, j, k, n;
	cin >> n;
	bool legal;
	int cnt = 0;
	double sum = 0,temp;
	for (i = 0; i < n; i++)
	{
		cin >> s;
		legal = true;
		legal = isLegal(s);
		if (!legal)
		{
			cout << "ERROR: "; cout << s;
			cout << " is not a legal number" << endl;
		}
		else 
		{
			double temp = stof(s);
			sum += temp;
			cnt++; 
		}
	}
	cout << "The average of ";
	cout << cnt<<" ";
	if (cnt == 1) cout << "number is ";
	else cout << "numbers is ";
	if (cnt == 0) cout << "Undefined";
	else printf("%.2lf", sum / cnt);
	cout << endl;
	return 0;

}

猜你喜欢

转载自blog.csdn.net/qq_40883132/article/details/81603635
今日推荐