UVA - 11464 Even Parity (枚举)

We have a grid of size N ×N. Each cell of the grid initially contains a zero(0) or a one(1). The parity of a cell is the number of 1s surrounding that cell. A cell is surrounded by at most 4 cells (top, bottom, left, right). Suppose we have a grid of size 4×4: 1 0 1 0 The parity of each cell would be 1 3 1 2 1 1 1 1 2 3 2 1 0 1 0 0 2 1 2 1 0 0 0 0 0 1 0 0
For this problem, you have to change some of the 0s to 1s so that the parity of every cell becomes even. We are interested in the minimum number of transformations of 0 to 1 that is needed to achieve the desired requirement.
Input
The first line of input is an integer T (T < 30) that indicates the number of test cases. Each case starts with a positive integer N (1 ≤ N ≤ 15). Each of the next N lines contain N integers (0/1) each. The integers are separated by a single space character.
Output
For each case, output the case number followed by the minimum number of transformations required. If it’s impossible to achieve the desired result, then output ‘-1’ instead.
Sample Input
3

3

0 0 0

0 0 0

0 0 0

3

0 0 0

1 0 0

0 0 0

3

1 1 1

1 1 1

0 0 0
Sample Output
Case 1: 0

Case 2: 3

Case 3: -1

白书思路:枚举第一行,通过第一行就可以对应的知道其他的数值。

白书代码:

#include<algorithm>
#include<string.h>
#include<stdio.h>
#define inf 0x3f3f3f
using namespace std;
int t,n;
int A[20][20],B[20][20];
int check(int s)
{
    memset(B,0,sizeof(B));
    for(int i=0;i<n;i++)
    {
        if(s&(1<<i)) B[0][i]=1;//枚举所有情况
        else if(A[0][i]==1) return  inf;//1不能变成0
    }
    int sum;
    for(int i=0;i<n-1;i++)
    {
        for(int j=0;j<n;j++)
        {
            sum=0;//计算上左右的和
            if(i>0) sum+=B[i-1][j];
            if(j>0) sum+=B[i][j-1];
            if(j<n-1) sum+=B[i][j+1];
            B[i+1][j]=sum%2;
            if(A[i+1][j]==1&&B[i+1][j]==0) return inf;
        }
    }
    int ans=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            if(B[i][j]!=A[i][j]) ans++;
        }
    }
    return ans;
}
int main()
{
    scanf("%d",&t);
    for(int ph=1;ph<=t;ph++)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                scanf("%d",&A[i][j]);
        }
        int ans=inf;
        for(int i=0;i<(1<<n);i++)
        {
            ans=min(ans,check(i));
        }
        printf("Case %d: ",ph);
        if(ans>225)//15x15=255
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/81197741
今日推荐