杭电oj JAVA:1000,1001,1002

1000 A + B Problem

/**
Problem Description 
Calculate A + B.

Input 
Each line will contain two integers A and B. Process to end of file.

Output 
For each case, output A + B in one line.

**/


import java.util.Scanner;
public class Main{
	public static void main(String[] args){
		Scanner in = new Scanner(System.in);
		while(in.hasNextInt())
		{
			int a = in.nextInt();
			int b = in.nextInt();
			System.out.println(a+b);
		}
	}
}

1001 Sum Problem

​
/**


Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.


Input

The input will consist of a series of integers n, one integer per line.


Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.


Sample Input

1
100

Sample Output

1

5050

**/
import java.util.Scanner;

public class Main {
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
			while(sc.hasNextInt()){
				int a = sc.nextInt();
				int sum = 0;
				for(int i = 1;i<=a;i++){
					sum+=i;
				}
				System.out.println(sum);
				System.out.println();
				
			}
	}
}

​
1002 A + B Problem II
/**
Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.


Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.


Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

**/
import java.util.Scanner;
import java.math.BigInteger;
public class Main {
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
			for(int i=0;i<n;i++){
				BigInteger a = sc.nextBigInteger();
				BigInteger b = sc.nextBigInteger();
				BigInteger c = a.add(b);
				
				System.out.println("Case "+(i+1)+":");
				System.out.println(a+" + "+b+" = "+c);
				
				if(i!=n-1){
					//第一个输出后换行   最后一个不换行
					System.out.println();
				}
			}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_39212193/article/details/81504489