HDU - 2120 Ice_cream's world I

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3

题解:

m个塔,n个两两塔建造起围墙,问能有几个圈。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[1100],sum;
int getf(int u)
{
    if(f[u]!=u)
        f[u]=getf(f[u]);
    return f[u];
}
void mergee(int u,int v)
{
    int t1=getf(u),t2=getf(v);
    if(t1==t2&&u!=v)
    {
        sum++;
    }
    f[t2]=t1;
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        sum=0;
        int a,b,i,j;
        for(i=0; i<m; i++)
            f[i]=i;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&a,&b);
            mergee(a,b);
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GJLfly/article/details/81746584