2018 Multi-University Training Contest 5.Everything Has Changed

Everything Has Changed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3444    Accepted Submission(s): 909
Special Judge

 

Problem Description

Edward is a worker for Aluminum Cyclic Machinery. His work is operating mechanical arms to cut out designed models. Here is a brief introduction of his work.
Assume the operating plane as a two-dimensional coordinate system. At first, there is a disc with center coordinates (0,0) and radius R. Then, m mechanical arms will cut and erase everything within its area of influence simultaneously, the i-th area of which is a circle with center coordinates (xi,yi) and radius ri (i=1,2,⋯,m). In order to obtain considerable models, it is guaranteed that every two cutting areas have no intersection and no cutting area contains the whole disc.
Your task is to determine the perimeter of the remaining area of the disc excluding internal perimeter.
Here is an illustration of the sample, in which the red curve is counted but the green curve is not.

 

Input

The first line contains one integer T, indicating the number of test cases.
The following lines describe all the test cases. For each test case:
The first line contains two integers m and R.
The i-th line of the following m lines contains three integers xi,yi and ri, indicating a cutting area.
1≤T≤1000, 1≤m≤100, −1000≤xi,yi≤1000, 1≤R,ri≤1000 (i=1,2,⋯,m).

 

Output

For each test case, print the perimeter of the remaining area in one line. Your answer is considered correct if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a and the jury's answer be b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.

 

Sample Input

 

1 4 10 6 3 5 10 -4 3 -2 -4 4 0 9 1

 

Sample Output

 

81.62198908430238475376

解题思路:利用余弦定理及三边长度求出两个角,剩下正常操作即可。

#include<bits/stdc++.h>
using namespace std;
#define pi acos(-1.0)

int main()
{
    int t,m;
    scanf("%d",&t);
    double R;
    while(t--&&scanf("%d%lf",&m,&R))
    {
        double ans=0,x,y,r,a1,a2,a3;
        ans=2*pi*R;
        for(int i=0; i<m; i++)
        {
            scanf("%lf%lf%lf",&x,&y,&r);
            a3=sqrt(x*x+y*y);
            if(R+r<=a3||R-r>a3) continue;
            else if(R-r==a3) ans+=2*pi*r;
            else
            {
                a1=R,a2=r;
                double w=acos((a2*a2+a3*a3-a1*a1)/(2*a2*a3));
                double ww=(w)*2*r;
                ans+=ww;
                double www=acos((a1*a1+a3*a3-a2*a2)/(2*a1*a3));
                ans-=www*2*R;
            }
        }
        printf("%.11f\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/XxxxxM1/article/details/81475053
今日推荐