E - Stones 优先队列

来源1896

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

奇数次数的石头往前题,偶数不踢,求最远的,优先队列

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define scf(x) scanf("%d",&x)
#define scff(x,y) scanf("%d%d",&x,&y)
#define prf(x) printf("%d\n",x) 
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+7;
const double eps=1e-8;
const int inf=0x3f3f3f3f;
using namespace std;
const double pi=acos(-1.0);
const int N=3e2+10;
struct stone
{
    int dis,pos;
    friend bool operator <(stone a,stone b)
    {
        if(a.pos==b.pos)
        return a.dis>b.dis;
        return a.pos>b.pos;
    }
}; 
priority_queue<stone> v;
priority_queue<stone> q;
int main()
{
    int re;
    stone t;
    scf(re);
    while(re--)
    {
        int n;scf(n);
        while(!v.empty()) v.pop();
        while(!q.empty()) q.pop();
        while(n--)
        {
            scff(t.pos,t.dis);
            v.push(t); 
        }
        int cas=1;
        while(!v.empty())
        {
            
            if(cas&1)
            {
                t=v.top();
                v.pop();
                t.pos +=t.dis;
                v.push(t); 
            }else
            {
                q.push(v.top());
                v.pop(); 
            }
            cas++;
        }
        while(q.size()>1) q.pop();
        t=q.top();
        prf(t.pos);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wzl19981116/p/9498346.html
今日推荐