KMP hdu1686 poj3461 Oulipo

链接 pojhttp://poj.org/problem?id=3461

hduacm.hdu.edu.cn/showproblem.php?pid=1686

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word Win the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

魔改的kmp板子,可能还会有错

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
const int maxn = 1e6+10;

int n, m, cnt;
char s1[maxn], s2[maxn];
int a[maxn];

void getnext()
{
	int i=1, j=0;
	a[0] = 0;
	while(i<m)
	{
		if(s2[i]==s2[j])
			a[i++] = ++j;
		else if(!j)
			i++;
		else j = a[j-1];
	}
}

int kmp()
{
	int i=0, j=0;
	while(i<n&&j<m)
	{
		if(s1[i]==s2[j])
		{
			i++;
			j++;
		}
		else if(!j)
			i++;
		else j = a[j-1];
		if(j==m)
		{
			cnt++;
			j=a[j-1];
		}
	}
	return cnt;
}

int main()
{
	int t, i;
	cin>>t;
	while(t--)
	{
		scanf("%s", s2);
		scanf("%s", s1);
		m = strlen(s2);
		n = strlen(s1);
		getnext();
		cnt = 0;
		cout<<kmp()<<endl;
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/Jqmjyj/article/details/81806706