Piotr's Ants UVA - 10881 (思维的体操)

“One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords.”
Kent Brockman
Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing
either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they
both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each
of the ants starts and which direction it is facing and wants to calculate where the ants will end up T
seconds from now.
Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line
containing 3 integers: L , T and n (0 ≤ n ≤ 10000). The next n lines give the locations of the n ants
(measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output
For each test case, output one line containing ‘Case #x:’ followed by n lines describing the locations
and directions of the n ants in the same format and order as in the input. If two or more ants are at
the same location, print ‘Turning’ instead of ‘L’ or ‘R’ for their direction. If an ant falls off the pole
before T seconds, print ‘Fell off’ for that ant. Print an empty line after each test case.
Sample Input
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Sample Output
Case #1:
2 Turning
6 R
2 Turning
Fell off
Case #2:
3 L
6 R
10 R
思路: 把握两个特点蚂蚁碰撞后掉头从整体上相当于对穿而过,蚂蚁的相对位置不变。
AC的C++程序如下:

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
const int maxn = 10005;
int id[maxn];
struct ant
{
    int id, pos, direct;//输入的序号,位置,朝向,1代表右,-1代表左
}an[maxn], change[maxn];
bool cmp(ant a,ant b)
{
    return a.pos < b.pos;
}
int main()
{
    int t, kase = 1;
    cin >> t;
    while (t--)
    {
        int len, time, n;
        cin >> len >> time >> n;
        for (int i = 0; i < n; i++)
        {
            char op;
            an[i].id = i;
            cin >> an[i].pos >> op;
            an[i].direct = (op == 'R' ? 1 : -1);

        }
        sort(an, an + n, cmp);
        for (int i = 0; i < n; i++)
        {
            id[an[i].id] = i; // 保存每个序号蚂蚁的位置
            change[i].pos = (an[i].pos + time*an[i].direct), change[i].direct = an[i].direct;//之后一定有蚂蚁处于这样的状态
        }
        sort(change, change + n, cmp);
        for (int i = 0; i < n - 1; i++)
        {
            if (change[i].pos == change[i + 1].pos)
            {
                change[i].direct = change[i + 1].direct = 0;
            }
        }
        printf("Case #%d:\n", kase++);
        for (int i = 0; i < n; i++)
        {
            if (change[id[i]].pos > len || change[id[i]].pos < 0)
            {
                cout << "Fell off" << endl;
            }
            else
            {
                cout << change[id[i]].pos << " ";
                if (change[id[i]].direct == 1) cout << "R" << endl;
                else if (change[id[i]].direct == -1) cout << "L" << endl;
                else cout << "Turning" << endl;
            }
        }
        cout << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jinduo16/article/details/81739575