The order of a Tree

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

题意的意思是给你一个序列,让你构造一个二叉树然后输出他的前序遍历(其实就是弄了一颗前序遍历符合答案的二叉树),然后我就过了,挺神奇的。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 101010
int t[N],l[N],r[N],a[N],flag,n,m;
void cn(int x,int y)//利用递归建立左右树
{
    if(y<=t[x])
    {
        if(l[x])//左小又大规则
            cn(l[x],y);
        else
            l[x]=flag;
    }
    else
    {
        if(r[x])
            cn(r[x],y);
        else
            r[x]=flag;
    }
}
void cm(int x)//先序遍历存储到a数组
{
    a[m++]=t[x];
    if(l[x])
        cm(l[x]);
    if(r[x])
        cm(r[x]);
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        int root=-1,x;
        flag=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            if(root==-1)
                t[++root]=x;//创建父亲节点
            else
            {
                t[++flag]=x;
                cn(root,x);
            }
        }
        m=0;
        cm(root);
        for(int i=0; i<m; i++)
            if(i!=m-1)
                printf("%d ",a[i]);
            else
                printf("%d\n",a[i]);

    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/aini875/article/details/81780881