SDUT1006——Sum Problem

版权声明:叁土 https://blog.csdn.net/qq_42847312/article/details/82014186

Sum Problem
Time Limit: 500 ms Memory Limit: 32768 KiB

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1
5050


AC代码:


#include <bits/stdc++.h>
using namespace std;
int main()
{
    long long n,s;
    while(cin>>n)
    {
        if(n%2==0) s=n/2+(n/2)*n;
        else s=n+(n/2)*n;
        cout<<s<<endl;
    }
    return 0;
}


余生还请多多指教!

猜你喜欢

转载自blog.csdn.net/qq_42847312/article/details/82014186