6116.Shortest Distance

问题 E: Shortest Distance (20)

时间限制: 1 Sec  内存限制: 32 MB
提交: 971  解决: 297
[提交][状态][讨论版][命题人:外部导入]

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7
#include<iostream>
#include<algorithm>
using namespace std;

long long a[100050] = { 0 }, b[100050] = { 0 };
//注:在vs中1e5以上数组需要设置为全局变量
int main() {
	int N, M, x, y;
	cin >> N;
	for (int i = 1; i <= N; i++) {
		cin >> a[i];
	}
	for (int i = 1; i <= N; i++) {
		b[i] = b[i - 1] + a[i - 1];
	}
	cin >> M;
	while (M--) {
		long long left = 0, right = 0;
		cin >> x >> y;
		if (x > y) {
			swap(x, y);
		}
		left = b[y] - b[x];
		right = b[N] - b[y] + b[x] + a[N];
		cout << min(left, right) << endl;
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36502291/article/details/82079434
今日推荐