HDU4006 The kth great number(优先队列)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/81636181

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 14419    Accepted Submission(s): 5586

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3

I 1

I 2

I 3

Q

I 5

Q

I 4

Q

Sample Output

1

2

3

Hint

Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

大概题意是求数组中第3大的数字。

题解:用优先队列可以自动升序排序。让队列中只存k个数,队头就是第k个大的数。

具体代码如下:

#include<iostream>
#include<queue>
#include<cstdlib>
using namespace std;
int main()
{
	int n,k;
	while(cin>>n>>k)
	{
		char str;
		priority_queue<int,vector<int>,greater<int> > s;
		for(int i=0;i<n;i++)
		{
			cin>>str;
			if(str=='I')
			{
				int num;
				cin>>num;
				s.push(num);
			}
			if(s.size()>k)
				s.pop();
			if(str=='Q')
				cout<<s.top()<<endl;
		}
	}
	return 0;
}

优先队列简单介绍:https://blog.csdn.net/qq_42391248/article/details/81149170

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/81636181