2018 Multi-University Training Contest 3(部分题解)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37444209/article/details/81986402

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 2004    Accepted Submission(s): 911

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

Sample Input

1

3

2 2 2

1 2

1 3

Sample Output

Q

#include <bits/stdc++.h>
#define ios1 ios::sync_with_stdio(0);
#define ios2 cin.tie(0);
#define LL long long
using namespace std;
const int maxn = 1e6 + 10;
int w[maxn];

int main() {
    int T, n;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        int u, v, p = -1;
        int Max = -1;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &w[i]);
            if(Max < w[i]) {
                Max = w[i];
                p = i;
            }
        }
        for(int i = 1; i <= n-1; i++)scanf("%d%d", &u, &v);
        int r = 0;
        for(int i = 1; i <= n; i++) {
            if(i != p)r ^= w[i];
        }
        if(r == Max) printf("D\n");
        else printf("Q\n");
    }
    return 0;
}

Problem D. Euler Function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1474    Accepted Submission(s): 1062

Problem Description

In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤kn for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.

Input

The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).

Output

For each test case, print a single line containing an integer, denoting the answer.

Sample Input

2

1

2

Sample Output

5

7

题意:给出一个复合数的定义,相当于就是合数, 求第k个最小正整数n, 并且使φ(n)为复合数.

题解:知道欧拉函数的,一下就能发现只有当k == 1时,n == 5, 其他的在 n >= 7之后的数都为复合数.

#include<bits/stdc++.h>
using namespace std;

int main() {
    int T, k;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &k);
        if(k == 1) printf("5\n");
        else printf("%d\n", k + 5);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37444209/article/details/81986402