PAT甲级--1138 Postorder Traversal(25 分)【前序+中序转成后序+输出中序第一个】

1138 Postorder Traversal(25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

解题思路 :前序中序转换成后序,这个只要套一下就好了,我之前将他们的转换的函数写在博客上了,只要套一下就好了,然后这题是要输出后序遍历第一个,所以就用flag来做标记,如果输出,就将flag变成1,一旦它变成1函数就退出,具体见代码。

#include<bits/stdc++.h>
using namespace std;
vector<int>pre,in;
int flag=0;
void postOrder(int root,int start,int end)
{
	if(start>end||flag==1) return ;
	int i=start;
	while(start<end&&pre[root]!=in[i]) i++;
	postOrder(root+1,start,i-1);
	postOrder(root+i-start+1,i+1,end);
	if(flag==0)
	{
		printf("%d\n",pre[root]);
		flag=1;
	}
}
int main(void)
{
	int n;
	scanf("%d",&n);
	pre.resize(n);
	in.resize(n);
	for(int i=0;i<n;i++) scanf("%d",&pre[i]);
	for(int i=0;i<n;i++) scanf("%d",&in[i]);
	postOrder(0,0,n-1);
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82251244
今日推荐