PAT甲级--1146 Topological Order(25 分)【判断是否为拓扑序列】

1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

解题思路:做这题之前首先要先去了解什么是拓扑排序,可以参考https://blog.csdn.net/qq_35644234/article/details/60578189

然后判断是否是拓扑序列,每个选项的元素输入的时候要去判断它的入度是否为0,如果不是的话做一个标记。在存储的时候是用邻接表,然后用一个数组来统计每个点的入度,然后就可以开始判断了。在判断的时候,我们要将与这个点去掉,也就是这个点连接的所有点的入度都减了1,具体见代码吧。

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	int n,m,a,b,x,ind,flag=0,in[1010];//入度
	vector<int>v[1010];
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&a,&b);
		v[a].push_back(b);
		in[b]++;
	}
	scanf("%d",&ind);
	for(int i=0;i<ind;i++)
	{
		int judge=1;
		vector<int>cntin(in,in+n+1);//将数组in赋值给cntin
		for(int j=0;j<n;j++)
		{
			scanf("%d",&x);
		    if(cntin[x]!=0) judge=0;//judge判断是不是拓扑排序
			for(int it:v[x]) cntin[it]--; //对v[x]的所有元素的入度的数量都减一
		}
		if(judge==1) continue;
		printf("%s%d",flag==1?" ":"",i);//控制打印格式,flag是判断是不是第一个输出
		flag=1;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82143040