ACM-ICPC 2018 南京赛区网络预赛__A. An Olympian Math Problem【规律水题】

  •  1000ms
  •  65536K

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k!=1×2×⋯×(k−1)×k

We denote S:

S=1×1!+2×2!+⋯+(n−1)×(n−1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer nn.

It is guaranteed that 2≤n≤10^18.

Output

For each test case, print an integer S modulo n.

Hint

The first test is: S=1×1!=1, and 1 modulo 2 is 1.

The second test is: S=1×1!+2×2!=5 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2

题目来源

ACM-ICPC 2018 南京赛区网络预赛

题目大意:S=1×1!+2×2!+⋯+(n−1)×(n−1)!求S mod n的值

题解:(n-1)*(n-1)!=n!-(n-1)! 因此S=n!-1所以S mod n=n-1

经验:比赛时强队和弱队都刷刷地过了,通过率极高,而且解决的时间快,以后遇到这种情况就要考虑会不会是简单的水题。要懂得这种现象给你传递的信息。

AC的C++代码:

#include<iostream>

using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		long long x;
		scanf("%lld",&x);
		printf("%lld\n",x-1LL);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/82289139