POJ 1655 Balancing Act【树形dp】【树的重心】

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 


Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

题意:

树的重心也叫树的质心。找到一个点,其所有的子树中最大的子树节点数最少,那么这个点就是这棵树的重心,删去重心后,生成的多棵树尽可能平衡。

找到树的重心

分析:

树形dp

以x为根节点的子树的个数记录

size[x]+=size[v[i]];///以x为根的子树中结点的个数

各个子树的节点个数的最大值
 f[x]=max(f[x],size[v[i]]);

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 20003
using namespace std;
int n,m,t;
int next[N*2],point[N*2],v[N*2],size[N*2],f[N],tot;
void add(int x,int y)
{
	tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y; 
	tot++; next[tot]=point[y]; point[y]=tot; v[tot]=x;
}
void dfs(int x,int fa)
{
	size[x]=1;
	for (int i=point[x];i;i=next[i])
	 if (v[i]!=fa)
	 {
	 	dfs(v[i],x);
	 	size[x]+=size[v[i]];///以x为根的子树中结点的个数
	 	f[x]=max(f[x],size[v[i]]);///各个子树的节点个数的最大值
	 }
	f[x]=max(f[x],n-size[x]);///各个子树的节点个数的最大值
}
int main()
{
   scanf("%d",&t);
   for (int l=1;l<=t;l++)
   {
   	 scanf("%d",&n);
   	 tot=0;
   	 memset(f,0,sizeof(f));
   	 memset(point,0,sizeof(point));
   	 memset(next,0,sizeof(next));
   	 for (int i=1;i<n;i++)
   	  {
   	  	int x,y; scanf("%d%d",&x,&y);
   	  	add(x,y);
   	  }
   	 dfs(1,0);
   	 int ans=1000000000; int x=0;
   	 for (int i=1;i<=n;i++)
   	  if (ans>f[i])
   	   	 ans=f[i],x=i;
   	 printf("%d %d\n",x,ans);
   }
}

猜你喜欢

转载自blog.csdn.net/lml11111/article/details/81976569