【倍增ST表】 Glad You Came HDU6356

Glad You Came

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1829    Accepted Submission(s): 789


 

Problem Description

Steve has an integer array a of length n (1-based). He assigned all the elements as zero at the beginning. After that, he made m operations, each of which is to update an interval of a with some value. You need to figure out ⨁ni=1(i⋅ai) after all his operations are finished, where ⨁ means the bitwise exclusive-OR operator.
In order to avoid huge input data, these operations are encrypted through some particular approach.
There are three unsigned 32-bit integers X,Y and Z which have initial values given by the input. A random number generator function is described as following, where ∧ means the bitwise exclusive-OR operator, << means the bitwise left shift operator and >> means the bitwise right shift operator. Note that function would change the values of X,Y and Z after calling.


Let the i -th result value of calling the above function as fi (i=1,2,⋯,3m) . The i -th operation of Steve is to update aj as vi if aj<vi (j=li,li+1,⋯,ri) , where

⎧⎩⎨⎪⎪lirivi=min((f3i−2modn)+1,(f3i−1modn)+1)=max((f3i−2modn)+1,(f3i−1modn)+1)=f3imod230(i=1,2,⋯,m).

 

Input

The first line contains one integer T , indicating the number of test cases.
Each of the following T lines describes a test case and contains five space-separated integers n,m,X,Y and Z .
1≤T≤100 , 1≤n≤105 , 1≤m≤5⋅106 , 0≤X,Y,Z<230 .
It is guaranteed that the sum of n in all the test cases does not exceed 106 and the sum of m in all the test cases does not exceed 5⋅107 .

 

Output

For each test case, output the answer in one line.

 

Sample Input

 

4 1 10 100 1000 10000 10 100 1000 10000 100000 100 1000 10000 100000 1000000 1000 10000 100000 1000000 10000000

 

Sample Output

 
1031463378 1446334207 351511856 47320301347

Hint

In the first sample, a = [1031463378] after all the operations. In the second sample, a = [1036205629, 1064909195, 1044643689, 1062944339, 1062944339, 1062944339, 1062944339, 1057472915, 1057472915, 1030626924] after all the operations.  

Source

2018 Multi-University Training Contest 5

#include <bits/stdc++.h>
using namespace std;

#define ui unsigned int
#define ll long long

const int mn = 1e5 + 10, mm = 5e6 + 10;

ui X, Y, Z;
ui f[3 * mm];
ui st[mn][20];
ui RNG()
{
	X = X ^ (X << 11);
	X = X ^ (X >> 4);
	X = X ^ (X << 5);
	X = X ^ (X >> 14);
	ui W = X ^ (Y ^ Z);
	X = Y;
	Y = Z;
	Z = W;
	return Z;
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("C:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE

	int T;
	scanf("%d", &T);
	while (T--)
	{
		memset(st, 0, sizeof st);

		ui n, m;
		scanf("%u %u %u %u %u", &n, &m, &X, &Y, &Z);

		for (ui i = 1; i <= 3 * m; i++)
			f[i] = RNG();

		for (ui i = 1; i <= m; i++)
		{
			ui l = min(f[3 * i - 2] % n + 1, f[3 * i - 1] % n + 1);
			ui r = max(f[3 * i - 2] % n + 1, f[3 * i - 1] % n + 1);
			ui v = f[3 * i] % (1 << 30);
			ui temp = log2(r - l + 1);
			/// 更新 l 为起点 长度为 (1 << temp) 的区间
			/// 更新 另一半长度为 (1 << temp) 的区间
			st[l][temp] = max(v, st[l][temp]);
			st[r - (1 << temp) + 1][temp] = max(v, st[r - (1 << temp) + 1][temp]);
		}

		/// 反向st表
		for (ui i = log2(n); i >= 1; i--)  /// 区间长度从大到小枚举更新
		{
			for (ui j = 1; j <= n; j++) 	/// 从前往后枚举
			{
				if ((j + (1 << i)) - 1 > n) /// 越界
					break;
				/// 更新 st[j][i] 的两半子集
				st[j][i - 1] = max(st[j][i - 1], st[j][i]);
				st[j + (1 << (i - 1))][i - 1] = max(st[j + (1 << (i - 1))][i - 1], st[j][i]);
			}
		}

		ll sum = 0;
		for (ui i = 1; i <= n; i++)
			sum ^= (ll)i * (ll)st[i][0];
		printf("%lld\n", sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81491112
今日推荐