hdu1010【dfs题】

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

思路:

步数与时间恰好到达D处,才输出Yes,否则就输出NO。。。。。。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int NP=9;
char map[NP][NP];
int sx,sy,dx,dy;
int flag;
int m,n,t;
int ds[4][2]={0,1,1,0,0,-1,-1,0};
void dfs(int x,int y,int t)
{
        printf("(%d,%d)-->",x,y);
       if(flag==1) return;
       if(t<abs(dx-x)+abs(dy-y)||(t-abs(x-dx)-abs(dy-y))%2) return ;//减枝 
       else if(t==0) 
       {
              if(x==dx&&y==dy)
              {
                    flag=1;
                    return;
              }
              else return;
       }
       else
       {
              for(int i=0;i<4;i++)
              {       int tx,ty;
                      tx=x+ds[i][0];
                      ty=y+ds[i][1];
                      if(tx>0&&tx<=n&&ty>0&&ty<=m&&(map[tx][ty]=='D'||map[tx][ty]=='.'))
                      {
                              
                            map[tx][ty]='X';
                            dfs(tx,ty,t-1);
                            map[tx][ty]='.';//回溯需要还原map[tx][ty] 
                      }
              }
       }
}
int main()
{
       
       char temp[10];
       while(cin>>n>>m>>t)
       {
              flag=0;            
              if(n==0&&m==0&&t==0) break;
              for(int i=1;i<=n;i++)
              {
                      scanf("%s",temp);
                      for(int j=1;j<=m;j++)
                      {
                              map[i][j]=temp[j-1];
                              if(map[i][j]=='S') {sx=i;sy=j;}//记录起点 
                              if(map[i][j]=='D'){dx=i;dy=j;}//记录终点 
                      }
              }
              dfs(sx,sy,t);
              //cout<<flag<<endl;
              if(flag==0) printf("NO\n");
              else printf("YES\n");
       }
       system("pause");
       return 0;

 }

扫描二维码关注公众号,回复: 3083077 查看本文章

猜你喜欢

转载自blog.csdn.net/sf_yang35/article/details/81348741