【最小表示法+set去重】P - How many HDU - 2609

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4011    Accepted Submission(s): 1821


 

Problem Description

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

 

Input

The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').

 

Output

For each test case output a integer , how many different necklaces.

 

Sample Input

 

4

0110

1100

1001

0011

4

1010

0101

1000

0001

 

Sample Output

 

1

2

 

Author

yifenfei

 

Source

奋斗的年代

#include <bits/stdc++.h>
using namespace std;

int len;
int cal_Min(char ch[])
{
	int i = 0, j = 1, k = 0;
	while (i < len && j < len && k < len)
	{
		char a = ch[(i + k) % len];
		char b = ch[(j + k) % len];

		if (a == b)
			k++;
		else
		{
			if (a > b)
				i = i + k + 1;
			else
				j = j + k + 1;
			k = 0;

			if (i == j)
				j++;
		}
	}
	return min(i, j);
}

set<string> Set;

int main()
{
#ifndef ONLINE_JUDGE
	freopen("C:\\in.txt", "r", stdin);
#endif // ONLINE_JUDGE

	int n;
	while (~scanf("%d", &n))
	{
		Set.clear();
		while (n--)
		{
			char ch[110];
			scanf("%s", ch);

			len = strlen(ch);
			int pos = cal_Min(ch);
			/// 旋转后相同的字符串 = 他们经过不同次旋转得到的最小表示相同

			char t[110];
			int w = 0;
			for (int i = pos; ; i = (i + 1) % len)
			{
				t[w++] = ch[i];
				if (w == len)
					break;
			}
			t[len] = '\0';
			Set.insert(t);
			/// 字符串 set 声明时用string, 插入时用char[]
		}
		printf("%d\n", Set.size());
	}
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/82381606