201771010102 常惠琢实验三 Java基本程序设计(2)

实验三 Java基本程序设计(2

实验时间 2018-9-13

1、实验目的与要求

(1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

(2)熟悉PTA平台线上测试环境;

(3)掌握Java语言构造基本程序语法知识(ch1-ch3);

(4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序

2、实验内容和步骤

实验1采用个人账号登录https://pintia.cn/,使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

实验2-实验3在课后完成

实验2公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证号的年月日抽取出来,按年-月-日格式输出。注意:输入使用Scanner类的nextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

代码如下:

import java.util.*;

public class Identity{

  public static void main(String args[]){

    @SuppressWarnings("resource")

       Scanner s=new Scanner(System.in);

    System.out.print("请输入你的身份证号码(必须为数字或x):");

    String l=s.nextLine();

    if(l=="")

    {

      System.out.print("身份证号码不能为空!");

     }

      else if(l.length()<19&&l.length()>17)

        {

          System.out.print("你输入的18为身份证号码为:"+l);

        }

      else

        {

          System.out.print("你输入的身份证位数不正确!");

        }

    String str=l.substring(6,10);

       String str1=l.substring(10,12);

       String str2=l.substring(12,14);

       System.out.println("您的生日是"+str+"年"+str1+"月"+str2 +"日");

  }

}

  

                

实验3studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:(1)输入姓名查询学号;(2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

(1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

(2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

(3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

代码如下:

import java.io.BufferedReader;

import java.io.File;

import java.io.FileInputStream;

import java.io.IOException;

import java.io.InputStreamReader;

import java.io.PrintWriter;

public class First {

/**

* @throws IOException

*/

public static void main(String[] args) throws IOException {

/*

* 1:读取原文件

* 2:项目标文件中写

* 3:使用缓冲流按行读写

*/

FileInputStream fis=new FileInputStream("src"+File.separator+"day01"+File.separator+"Test1.java");

 

//转化为字符输出流

InputStreamReader isr=new InputStreamReader(fis);

 

//按行为单位读取字符串

BufferedReader br=new BufferedReader(isr);

 

//

PrintWriter pw=new PrintWriter("Identity.java");

 

 String line=null;

 while((line=br.readLine())!=null){

pw.println(line);

 }

pw.close();

}

}

猜你喜欢

转载自www.cnblogs.com/hongyanohongyan/p/9657867.html