结构体排序问题

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input

 

3 6 4

2 2.5 5 1 3 4

5 1 3.5 2 2 2

1 1 1 1 1 10

3 3 2

1 2 3

2 3 1

3 1 2

Sample Output

 

6 5 3 1

2 1

题目描述:题意的大概意思就是不同的人为不同的图案打分,设计者挑选评论比较满意的几个作为设计标准,要尽可能满足更多人的需求。每个图案都标有序号,按倒序输出,如果图案的满意度相同,倒叙输出序号小的优先。

思路:因为有多个人对不同的图案打分,所以我们可以利用结构体储每个物品的序号以及所有人对它评分的和,用它的评分排序然后按要求输出序号就可以了。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct pai
{
    int num,sum;
}a[100000];
bool cmp(pai a,pai b)
{
    if(a.num>b.num)
        return true;
    else
        return false;
}
bool cmpe(pai a,pai b)
{
    if(a.sum>=b.sum)
        return true;
    else
        return false;
}

int main()
{
    int n,m,k;
    double s;
    while(scanf("%d %d %d",&n,&m,&k)!=EOF)
    {
        for(int i=0;i<m;i++)
        {
            a[i].num=0;
            a[i].sum=i+1;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%lf",&s);
                a[j].num+=s;
            }
        }
        sort(a,a+m,cmp);
        sort(a,a+k,cmpe);
        for(int j=0;j<k-1;j++)
        {
            printf("%d ",a[j].sum);
        }
        printf("%d\n",a[k-1].sum);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/pdsu_congshuang/article/details/82631603