【最小生成树专题】HDU 1102 Constructing Roads (已经修好部分路)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qian2213762498/article/details/82468598

http://acm.hdu.edu.cn/showproblem.php?pid=1102

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28986    Accepted Submission(s): 11038

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source

kicc

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1301 1272 1325 1217 1142 

思路

题目大意:先给你N个村庄之间距离,用矩阵表示。再告诉你S个已经建好的路。求再建多少距离的路,

能实现N个村庄全部联通。

思路:这种已经修好部分路的题,通常有两种思路:
1:把已经修好的边的边权设为0,再正常Kruskal
2:合并修好的边的两个端点,计算有效合并次数,Kruskal时接着这个cnt继续++,指导cnt==n-1? 

以下代码使用的是思路2.

AC Code

#include<iostream> 
#include<cstdio>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std; 
const int nmax=110;
const int mmax=10000+100;
int n,m,cnt;
struct Edge
{
    int u;
    int v;
    int val;
}edge[mmax];
 
bool cmp(Edge a,Edge b)
{
    return a.val < b.val;
}
 
int father[nmax];//,ans;
 
int findFather(int u){
	if(u==father[u]) return u;
	else{
		int f=findFather(father[u]);
		father[u]=f;
		return f;
	}
}
 
void Kruskal(int cnt)
{   int ans=0;
    sort(edge,edge+m,cmp);
    for(int i = 0; i < m; i++)
    {
        int fu = findFather(edge[i].u);
        int fv = findFather(edge[i].v);
        if(fu != fv)
        {
			father[fv] = fu; 
            cnt++;
            ans += edge[i].val;
            if(cnt == n-1)
                break;
        }
    }
    if(cnt == n-1)
        printf("%d\n",ans);
    else
        printf("-1\n");
}
int main()
{   
    while(scanf("%d",&n)!=EOF){
        for(int i = 1; i <= n; i++)
            father[i] = i;
        int x;
        int id=0;
        for(int i=1;i<=n;i++){
        	for(int j=1;j<=n;j++){
        		scanf("%d",&x);
        		edge[id].u=i;
        		edge[id].v=j;
        		edge[id].val=x;
        		id++;
			}
        }
        m=id;
        //printf("m:%d\n",m);
        cnt = 0;
        int u,v;
        int q;
        scanf("%d",&q);
        //printf("q:%d\n",q);
        for(int i = 0; i < q; i++){
            scanf("%d %d",&u,&v);
            //printf("u:%d v:%d",u,v);
            int fu = findFather(u);
            int fv = findFather(v);
            if(fu != fv){
                father[fv] = fu;
                cnt++;
            }
        }
        Kruskal(cnt);
    }
    return 0;
}
//这种已经修好部分路的题,通常有两种思路:
//1:把已经修好的边的边权设为0,再正常Kruskal
//2:合并修好的边的两个端点,计算有效合并次数,Kruskal时接着这个cnt继续++,指导cnt==n-1? 

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/82468598