[kuangbin带你飞]专题四 最短路练习 F - Wormholes

POJ - 3259

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

const int V=510;
const int E=10000;
const int INF=0x7fffffff;

struct EDGE
{
    int link,val,next;
}edge[E];

int map[V][V];
int head[V],cnt[V],dist[V];
bool vis[V];
int e;

void addedge(int x,int y,int c)
{
    edge[e].link=y;
    edge[e].val=c;
    edge[e].next=head[x];
    head[x]=e++;
}

bool relax(int u,int v,int val)
{
    if(dist[u]+val<dist[v])
    {
        dist[v]=dist[u]+val;
        return true;
    }
    return false;
}

bool SPFA(int src,int n)
{
    memset(vis,false,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    for(int i=1;i<=n;i++)  dist[i]=INF;
    dist[src]=0;
    vis[src]=true;
    queue<int> q;
    q.push(src);
    ++cnt[src];
    while(!q.empty())
    {
        int u,v;
        u=q.front();
        q.pop();
        vis[u]=false;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            v=edge[i].link;
            if(relax(u,v,edge[i].val)&&!vis[v])
            {
                q.push(v);
                vis[v]=true;
                ++cnt[v];
                if(cnt[v]>=n) return true;;
            }
        }
    }
    return false;
}

int main()
{
    int T,n,m,w;
    scanf("%d",&T);
    while(T--)
    {
        e=0;
        memset(map,-1,sizeof(map));
        memset(head,-1,sizeof(head));
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=m;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            if(map[x][y]==-1) map[x][y]=map[y][x]=c;
            else map[x][y]=map[y][x]=min(map[x][y],c);
        }
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
          if(map[i][j]!=-1)  addedge(i,j,map[i][j]);
        for(int i=1;i<=w;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            addedge(x,y,-c);
        }
        if(SPFA(1,n)) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40829921/article/details/81386768
今日推荐