Java——HDU——1073 Online Judge

Online Judge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10019    Accepted Submission(s): 3604


 

Problem Description

Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

 

Output

For each test cases, you should output the the result Judge System should return.

 

Sample Input

 

4 START 1 + 2 = 3 END START 1+2=3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 4 END START 1 + 2 = 3 END START 1 + 2 = 3 END

扫描二维码关注公众号,回复: 3353212 查看本文章
 

Sample Output

 

Presentation Error Presentation Error Wrong Answer Presentation Error


import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        for(int i=0;i<n;i++) {
            String right="",user="";
            while(true) {
                String str=sc.nextLine();
                if(str.equals("END"))
                break;
                if(str.equals("START"))
                    continue;
                right+=str;
                right+="\n";
            }
            while(true) {
                String str=sc.nextLine();
                if(str.equals("END"))
                break;
                if(str.equals("START"))
                    continue;
                user+=str;
                user+="\n";
            }
            if(user.equals(right)) {
                System.out.println("Accepted");
                continue;
            }
            else {
                String strr="",stru="";
                for(int j=0;j<right.length();j++) {
                    char t=right.charAt(j);
                    if(t!=' '&&t!='\t'&&t!='\n') 
                        strr+=t;
                    
                }
                for(int j=0;j<user.length();j++) {
                    char t=user.charAt(j);
                    if(t!=' '&&t!='\t'&&t!='\n') 
                        stru+=t;
                    }
                    if(strr.equals(stru)) 
                        System.out.println("Presentation Error");
                    else
                        System.out.println("Wrong Answer");
                
            }
        }    
    }
}

猜你喜欢

转载自blog.csdn.net/lannister_awalys_pay/article/details/82820761
今日推荐