Java——HDOJ——1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 204260    Accepted Submission(s): 51573


 

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

 

1 1 3 1 2 10 0 0 0

 

Sample Output

 

2 5

package HDU.dyg;

import java.util.Scanner;

public class Main {
        public static void main(String[] args)
        {
            Scanner input=new Scanner(System.in);
            int a,b,n;
            while(input.hasNext())
            {
                a=input.nextInt();
                b=input.nextInt();
                n=input.nextInt();
                if(n==1||n==2)
                {
                    System.out.println('1');
                    continue;
                }
                if((a==0&&b==0)||n==0)
                    break;
                int x=1,y=1,z=0;
                for(int i=3;i<=n%49;i++)
                {
                    z=(a*y+b*x)%7;
                    x=y;
                    y=z;
                }
                System.out.println(z);
            }
        }
}
 

猜你喜欢

转载自blog.csdn.net/lannister_awalys_pay/article/details/82727015