补个水题 :数水坑

描述
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.

Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output
* Line 1: The number of ponds in Farmer John’s field.

Sample Input
10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.
Sample Output
3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

代码如下:

#include<iostream>
#include<string.h>
using namespace std;

int run[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
char map[110][110];
int m,n,num=0,aa,bb;

void bfs(int a,int b){
    map[a][b]='.';
    for(int i=0;i<8;i++){
        aa=a+run[i][0];
        bb=b+run[i][1];
        if(map[aa][bb]=='W')bfs(aa,bb);
    }
}

int main()
{
    memset(map,'0',sizeof(map));
    cin>>m>>n;
    for(int i=1;i<=m;i++)
    for(int j=1;j<=n;j++){
        cin>>map[i][j];
    }
    for(int i=1;i<=m;i++)
    for(int j=1;j<=n;j++){
        if(map[i][j]=='W'){
            num++;
            bfs(i,j);
        }
    }
    cout<<num<<endl;
    return 0;
}

简单的bfs。。

猜你喜欢

转载自blog.csdn.net/wbl1970353515/article/details/82731680