HDU 4715 Difference Between Primes【素数之差,标记】

版权声明:但行好事,莫问前程。 https://blog.csdn.net/Li_Hongcheng/article/details/81176781

Difference Between Primes

Problem Description
All you know Goldbach conjecture.That is to say, Every even integer greater than 2 can be expressed as the sum of two primes. Today, skywind present a new conjecture: every even integer can be expressed as the difference of two primes. To validate this conjecture, you are asked to write a program.

Input
The first line of input is a number nidentified the count of test cases(n<10^5). There is a even number xat the next nlines. The absolute value of xis not greater than 10^6.

Output
For each number xtested, outputstwo primes aand bat one line separatedwith one space where a-b=x. If more than one group can meet it, output the minimum group. If no primes can satisfy it, output ‘FAIL’.

Sample Input
3
6
10
20

Sample Output
11 5
13 3
23 3

Source
2013 ACM/ICPC Asia Regional Online —— Warmup

#include<bits/stdc++.h>
using namespace std;
const int maxn=1000005;
int vis[2*maxn];
int prime[maxn];
int total;

void makeprime()
{
    total=0;
    memset(vis,0,sizeof(vis));
    prime[total++]=2;
    vis[2]=1;
    int flag;
    for(int i=3; i<=maxn; i+=2)
    {
        flag=1;
        for(int j=0; prime[j]*prime[j]<=i; j++)
        {
            if(i%prime[j]==0)
            {
                flag=0;
                break;
            }
        }
        if(flag)
        {
            prime[total++]=i;
            vis[i]=1;
        }
    }
}

int main()
{
    makeprime();
    int t,n,i;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0; i<=total; i++)
        {
            if(vis[prime[i]+abs(n)])
                break;
        }
        if(n>0)printf("%d %d\n",prime[i]+abs(n),prime[i]);
        else printf("%d %d\n",prime[i],prime[i]+abs(n));
    }
}

思路:
可能是水题吧,我太菜感觉还是有点难度。
先素数打表,然后把素数标记,然后从小到大开始遍历,如果是素数就停下来,这样满足最小的两个差。

猜你喜欢

转载自blog.csdn.net/Li_Hongcheng/article/details/81176781