PAT甲级 1071 Speech Patterns (25 分)map映射,STL的使用

1071 Speech Patterns (25 分)

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

 题目大意:统计单词个数~大小写字母+数字的组合才是合法的单词,给出一个字符串,求出现的合法的单词的个数最多的那个单词,以及它出现的次数。如果有并列的,那么输出字典序里面的第一个~~

#include <bits/stdc++.h>
using namespace std;

int main()
{
    map<string,int> mp;
    string str;
    while(1){
        cin>>str;
        string temp = "";
        for(int i=0;i<str.length();i++){
            if(isalpha(str[i]) || isalnum(str[i]))
                temp += tolower(str[i]);
            else{
                mp[temp] += 1;
                temp = "";
                continue;
            }
        }
        mp[temp] += 1;
        char ch = getchar();
        if(ch == '\n')
            break;
    }

    int max_val = 0;
    string res = "";
    for(auto it:mp){
        if(it.first == "")//若出现形如!!~~字符串,则mp[""]+=1
            continue;
        if(max_val < it.second){
            max_val = it.second;
            res = it.first;
        }
    }
    cout<<res<<" "<<max_val<<endl;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82946510