PAT甲级 1073 Scientific Notation (20 分)String的使用

1073 Scientific Notation (20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

Note: String字符串中的 substr 、erase 、insert 、 length 都要很熟练使用

          stoi 和 to_string 能让整形与字符串互相转换 

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    string str;
    cin>>str;

    if(str[0]=='-')
        cout<<"-";

    int e = str.find('E');//获取E的下标
    int ep = stoi(str.substr(e+1));//获取指数

    string num = str.substr(1,e-1);//截取1~e-1的字符串
    num = num.erase(1,1);//删除1位置的一个字符

    if(ep < 0){//当指数为负数时
        cout<<"0.";
        for(int i=0;i<abs(ep)-1;i++)
            cout<<0;
        cout<<num;
    }else{
        if(abs(ep) >= num.length() - 1){//此时没有小数点
            cout<<num;
            for(int i=0;i < abs(ep)-num.length()+1;i++)
                cout<<0;
        }else{
            num.insert(abs(ep)+1,".");
            cout<<num;
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82952957
今日推荐