(2)P - 贪心

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
 
 

035

贪心的思想是局部最优解,感觉有个套路就是用sort排序,主要是寻找以什么为标准排序,,题意P:因为整ACM,许多作业没有写,如果再规定期限内没有完成,会被扣分,一天只能完成一份作业,输入t表示t组测试数据,在输入n,表示有多少作业,再输入截至时间和扣除的分数,输出扣除最小分数,贪心思想:把扣分最大的优先完成,分数相同时,截至时间早优先,用一个数组做标记,那一天被用过则不能完成
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
bool use[10000];
struct node
{
 int scores;
 int deadlines;
}m[1001];
bool cmp(node x,node y)
{
 if(x.scores==y.scores)
 {
  return x.deadlines<y.deadlines;//截至时间
 }
 else
 {
  return x.scores>y.scores;//分数
 }
}
int main()

 int t,n,sum;
 int i,j,k;
 cin>>t;
 while(t--)
 {
  sum=0;
  memset(use,0,sizeof(use));
  cin>>n;
  for(i=0;i<n;i++)
  {
   cin>>m[i].deadlines;
  }
  for(i=0;i<n;i++)
  {
   cin>>m[i].scores;
  }
  sort(m,m+n,cmp);
  for(i=0;i<n;i++)//遍历每一份作业
  {
   for(j=m[i].deadlines;j>0;j--)//先从最后一天开始找,没有用过就,,
   {
    if(use[j]==0)
    {
     use[j]=1;
     break;
    }
   }
   if(j==0)
   {
    sum+=m[i].scores;//该作业完成不了
   }
  }
  cout<<sum<<endl;
 }
}

猜你喜欢

转载自blog.csdn.net/whhhzs/article/details/79338506