POJ 3494 Largest Submatrix of All 1’s (最大全1子矩阵 单调栈)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Tc_To_Top/article/details/82936339

Largest Submatrix of All 1’s

Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 8107   Accepted: 2947
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

Source

POJ Founder Monthly Contest – 2008.01.31

题目链接:http://poj.org/problem?id=3494

题目大意:求n*m的01矩阵中,全为1的面积最大子矩阵

题目分析:预处理出每个位置的高度,按照一维的方式对每行都求一次,时间复杂度O(nm)

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 2005;
int a[MAX][MAX], h[MAX], stk[MAX], n, m;

int main() {
    while (scanf("%d %d", &n, &m) != EOF) {
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= m; j++) {
                scanf("%d", &a[i][j]);
            }
        }
        int ans = 0;
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= m; j++) {
                h[j] = a[i][j] == 0 ? 0 : h[j] + 1;
            }
            int top = 0, res = 0, pos = 1;
            h[m + 1] = 0;
            while (pos <= m + 1) {
                if (top == 0 || h[pos] >= h[stk[top]]) {
                    stk[++top] = pos++;
                } else {
                    int cur = stk[top--];
                    int w = pos - stk[top] - 1;
                    res = max(res, w * h[cur]);
                }
            }
            ans = max(ans, res);
        }
        printf("%d\n", ans);
    }
}

猜你喜欢

转载自blog.csdn.net/Tc_To_Top/article/details/82936339